Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Electronic help needed

  1. #21
    Senior Member
    Join Date
    Mar 2014
    Location
    Charleston, West Virginia USA
    Posts
    611
    See if you can unplug the sensors and measure the pins on the board. Without seeing the diagram, I'm suspecting 5v as the power source.
    Bones

  2. #22
    Senior Member
    Join Date
    Jul 2008
    Location
    Suffolk, UK
    Posts
    1,486
    Fishbonz, I could argue the toss but it wouldn't be constructive to the thread, all the IR sense systems I have designed use modulation as a pre-requisite, be that at the emitter end or on board. I'll bow out thanks.

  3. #23
    Senior Member r4z0r7o3's Avatar
    Join Date
    Jul 2015
    Location
    Raleigh, North Carolina
    Posts
    1,316
    Quote Originally Posted by FishbonzWVa View Post
    See if you can unplug the sensors and measure the pins on the board. Without seeing the diagram, I'm suspecting 5v as the power source.
    This is a good idea. There's going to be a voltage-drop when the device is in parallel with the meter like this, so 3v is probably okay (it's really 5v when you're not looking).

    As for the low-ball measurement. Perhaps the printer was already in some kind of error-condition and had shutdown power / gone into a kind of sleep mode? Checking right before/after cold powerup is the best IMHO. Another possibility is, you've got a bad or "stuck" interlock switch somewhere (if there are any). Basically a "safety" device that turns things off when doors / lids / panels are open.

    My gut suggests this is a power supply problem. They all go bad eventually, many times, right along with electrolytic capacitors (sensitive to heat and drying out). When they fail, they don't always go out completely. Sometimes the result is funky DC ripples, spikes, and varying over/under voltage conditions. All of these things won't necessarily kill logic components outright, but it will make them act very strangely.

    Is there a way you can disconnect the power supply, yet convince it to turn "on", so you can measure the outputs (at the connectors)? It won't be 100% test, only measuring voltage w/o a load, and your DMM isn't measuring very fast. However, if something is WAY off, it will be apparent. e.g. if a +12v or +24v output reads 2.77556v or fluctuates wildly.

    Also take a peek around with a flashlight, and make sure there's no burst electrolitic caps. or ones with brown, tan, or black colored "goo" leaking out of them (bright white or clear is okay, it's just glue).
    "Things that are complex are not useful, things that are useful are simple."
    - Mikhail Kalashnikov

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •